Shopper: Missing per-action authorization on PaymentMethods, Currencies and Carriers admin tables
CVE-2026-47745GHSA-fxqw-97cc-7g5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopper/framework
- Affected
- < 2.8.0
- Fixed in
- 2.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fxqw-97cc-7g5c lists affected ranges: Packagist shopper/framework >=0 <2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-47745: 0.22% estimated exploitation activity in the next 30 days; percentile 12.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The admin tables for PaymentMethods, Currencies and Carriers exposed inline toggles and per-record actions (enable, disable, edit, delete) that were rendered for any authenticated panel user without checking the corresponding per-action permission. A low-privilege user could: - Disable every payment method on the store, blocking checkout. - Disable or alter the default currency, changing displayed prices and the exchange rate basis. - Disable carriers, breaking shipping rate computation at checkout. The impact is a full denial of checkout and pricing integrity loss, reachable by any authenticated user. Patches Fixed in v2.8.0. Each toggle and per-record action now requires its matching permission (editpaymentmethods, editcurrencies, editcarriers). Upgrade via: Workarounds None. Upgrade to v2.8.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fxqw-97cc-7g5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47745 Advisory: Shopper: Missing per-action authorization on PaymentMethods, Currencies and Carriers admin tables IDs: CVE-2026-47745, GHSA-fxqw-97cc-7g5c Record: https://patchnext.com/advisories/cve-2026-47745 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopper/framework: affected < 2.8.0; fixed in 2.8.0 ## Suggested inspection (read-only) - Packagist shopper/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopper/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fxqw-97cc-7g5c (GitHub-reviewed advisory GHSA-fxqw-97cc-7g5c lists affected ranges: Packagist shopper/framework >=0 <2.8.0) Commands are suggestions: review each one before running it.
Loading voting…