Skip to content

← Actionable
Critical, CVSS 9.9

Shopper: Authorization bypass and RBAC privilege escalation in team settings

CVE-2026-47744GHSA-c3qp-2ggw-xjg7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-47744: 0.32% estimated exploitation activity in the next 30 days; percentile 25.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Two distinct authorization defects in the team settings allowed any authenticated panel user to take over the RBAC system: - Settings/Team/Index had no mount() authorization. Any authenticated user could load the page and use its public actions to create new roles and delete other users, including administrators. - Settings/Team/RolePermission gated its write actions on the read-only viewusers permission. Any user holding viewusers could grant themselves or any other user arbitrary permissions, including manageusers and editorders, effectively escalating to full panel administrator from a read-only account. Combined, these two defects allow a low-privilege authenticated user to obtain administrator privileges and remove the legitimate administrators from the panel. Patches Fixed in v2.8.0: - Settings/Team/Index::mount() now authorizes against manageusers. - Settings/Team/RolePermission write actions now require manageusers instead of viewusers. Upgrade via: Workarounds None.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c3qp-2ggw-xjg7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47744

Advisory: Shopper: Authorization bypass and RBAC privilege escalation in team settings
IDs: CVE-2026-47744, GHSA-c3qp-2ggw-xjg7
Record: https://patchnext.com/advisories/cve-2026-47744 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.8.0; fixed in 2.8.0

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c3qp-2ggw-xjg7 (GitHub-reviewed advisory GHSA-c3qp-2ggw-xjg7 lists affected ranges: Packagist shopper/framework >=0 <2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…