Shopper: Missing authorization on Product admin Livewire sub-form components
CVE-2026-47742GHSA-h4mp-g9c6-xwph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopper/framework
- Affected
- < 2.8.0
- Fixed in
- 2.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4mp-g9c6-xwph lists affected ranges: Packagist shopper/framework >=0 <2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-47742: 0.22% estimated exploitation activity in the next 30 days; percentile 12.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sub-form Livewire components used in the product editor (Edit, Inventory, Seo, Shipping, Files) had no authorization on their store() method. Any authenticated panel user, regardless of role, could mutate any product's pricing, stock, SEO metadata, shipping dimensions, and attached media without holding editproducts. The affected components accepted the product ID as a public Livewire property without #[Locked], so an attacker could also target an arbitrary product by tampering with the wire payload from the client. Patches Fixed in v2.8.0. Each sub-form store() now authorizes against editproducts and the product binding is locked. Upgrade via: Workarounds None. Upgrade to v2.8.0. References - Pull request: https://github.com/shopperlabs/shopper/pull/511 - CWE-862 Missing Authorization
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4mp-g9c6-xwph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47742 Advisory: Shopper: Missing authorization on Product admin Livewire sub-form components IDs: CVE-2026-47742, GHSA-h4mp-g9c6-xwph Record: https://patchnext.com/advisories/cve-2026-47742 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopper/framework: affected < 2.8.0; fixed in 2.8.0 ## Suggested inspection (read-only) - Packagist shopper/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopper/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4mp-g9c6-xwph (GitHub-reviewed advisory GHSA-h4mp-g9c6-xwph lists affected ranges: Packagist shopper/framework >=0 <2.8.0) Commands are suggestions: review each one before running it.
Loading voting…