shopper/framework: Race condition on Discount.usage_limit allows silent over-redemption
CVE-2026-47741GHSA-9rh9-hf3w-9fgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/cart 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopper/cart
- Affected
- < 2.8.0
- Fixed in
- 2.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9rh9-hf3w-9fgg lists affected ranges: Packagist shopper/cart >=0 <2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-47741: 0.24% estimated exploitation activity in the next 30 days; percentile 15.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CreateOrderFromCartAction::execute previously created the Order row before checking and incrementing the discount's totaluse counter. Under concurrent checkout pressure (Black Friday, flash sale, viral coupon), the global usagelimit was silently exceeded: orders were committed with the discount fully applied to priceamount while the counter blocked at usagelimit. The merchant had no signal that an over-redemption had occurred. A second related bug: usagelimitperuser was effectively a no-op because the counter it relied on (DiscountDetail.totaluse) was never incremented anywhere in the codebase. The per-user check therefore always saw 0 uses and validation passed regardless of how many times the same customer had previously redeemed the coupon. For eligibility = Everyone the per-user limit could not fire at all because the underlying DiscountDetail row only exists for eligibility = Customers. Direct financial loss: each over-redemption is a discount the merchant did not intend…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9rh9-hf3w-9fgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47741 Advisory: shopper/framework: Race condition on Discount.usage_limit allows silent over-redemption IDs: CVE-2026-47741, GHSA-9rh9-hf3w-9fgg Record: https://patchnext.com/advisories/cve-2026-47741 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopper/cart 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopper/cart: affected < 2.8.0; fixed in 2.8.0 ## Suggested inspection (read-only) - Packagist shopper/cart: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopper/cart. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9rh9-hf3w-9fgg (GitHub-reviewed advisory GHSA-9rh9-hf3w-9fgg lists affected ranges: Packagist shopper/cart >=0 <2.8.0) Commands are suggestions: review each one before running it.
Loading voting…