Skip to content

← Actionable
High, CVSS 8.1

shopper/framework: Authorization bypass in multiple Livewire admin components

CVE-2026-47740GHSA-f946-9qp6-vgch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-47740: 0.26% estimated exploitation activity in the next 30 days; percentile 17.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Multiple Livewire components in the admin panel allowed an authenticated low-privilege user to mutate data without the required permission: - Order detail Filament actions (cancel, mark paid, mark complete, capture payment, archive, start processing) were callable with readorders only and did not require editorders. capturePayment could trigger an actual PSP capture. - Order shipments table actions (mark delivered, edit tracking) were callable with browseorders only. - Sub-form Livewire components for products (Edit, Inventory, Seo, Shipping, Files) had no authorization on store(), so any authenticated panel user could mutate product data without editproducts. - Settings/Team/Index had no mount() authorization at all — any authenticated user could create roles and delete other users. - Settings/Team/RolePermission gated its write actions on the read-only viewusers permission, allowing privilege escalation via the RBAC system itself. - PaymentMethods, Currencies, Carriers table…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f946-9qp6-vgch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47740

Advisory: shopper/framework: Authorization bypass in multiple Livewire admin components
IDs: CVE-2026-47740, GHSA-f946-9qp6-vgch
Record: https://patchnext.com/advisories/cve-2026-47740 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.8.0; fixed in 2.8.0

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f946-9qp6-vgch (GitHub-reviewed advisory GHSA-f946-9qp6-vgch lists affected ranges: Packagist shopper/framework >=0 <2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…