Skip to content

← Actionable
High, CVSS 7.5amended

Puma PROXY Protocol v1 Accepts Repeated Protocol Headers on Persistent Connections

CVE-2026-47737GHSA-2vqw-3mp8-cgmx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (puma 8.0.2, 7.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems puma

    Affected
    >= 8.0.0, < 8.0.2>= 5.5.0, < 7.2.1
    Fixed in
    8.0.2, 7.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-47737: 0.18% estimated exploitation activity in the next 30 days; percentile 7.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Puma is vulnerable to source IP spoofing when `set_remote_address proxy_protocol: :v1` is enabled and persistent connections are used. PROXY protocol v1 is a connection-level protocol. Support was added to Puma in v5.5.0. A proxy sends one PROXY header at the beginning of a TCP connection, before any HTTP data. Puma incorrectly re-parsed PROXY protocol headers after each keep-alive request on the same connection. An attacker able to send HTTP requests through a trusted proxy could therefore inject a second PROXY header between HTTP requests. Puma would treat the injected header as authoritative for the next request and overwrite `REMOTE_ADDR`. This can mislead applications or middleware that use `REMOTE_ADDR` for security decisions, rate limiting, auditing, or allow/deny lists. Only deployments that explicitly enable PROXY protocol v1 are affected, and will have set: ```ruby set_remote_address proxy_protocol: :v1 ``` Puma's…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-2vqw-3mp8-cgmx

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-2vqw-3mp8-cgmx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2vqw-3mp8-cgmx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47737

Advisory: Puma PROXY Protocol v1 Accepts Repeated Protocol Headers on Persistent Connections
IDs: CVE-2026-47737, GHSA-2vqw-3mp8-cgmx
Record: https://patchnext.com/advisories/cve-2026-47737 (revision 3, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: puma 8.0.2, 7.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems puma: affected >= 8.0.0, < 8.0.2; >= 5.5.0, < 7.2.1; fixed in 8.0.2, 7.2.1

## Suggested inspection (read-only)
- RubyGems puma: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on puma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2vqw-3mp8-cgmx (GitHub-reviewed advisory GHSA-2vqw-3mp8-cgmx lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-2vqw-3mp8-cgmx (OSV record GHSA-2vqw-3mp8-cgmx lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…