Puma PROXY Protocol v1 Parser Allows Remote Memory Exhaustion
CVE-2026-47736GHSA-qpgp-93vx-g8v8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (puma 8.0.2, 7.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems puma
- Affected
- >= 8.0.0, < 8.0.2>= 5.5.0, < 7.2.1
- Fixed in
- 8.0.2, 7.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpgp-93vx-g8v8 lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qpgp-93vx-g8v8 lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-47736: 0.35% estimated exploitation activity in the next 30 days; percentile 28.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact PROXY protocol support for Puma was added in version 5.5.0. When PROXY protocol v1 support is enabled, Puma reads incoming bytes into an internal buffer. It waits for "\r\n" to determine whether a PROXY v1 line is present. If an attacker opens a TCP connection and continuously sends bytes without CRLF, Puma keeps appending to this pre-parse buffer. This can cause unbounded in-process memory growth and additional CPU cost from repeatedly scanning the growing buffer for CRLF. A single, unauthenticated TCP connection can drive significant memory growth and may cause process/container OOM or degraded availability. Only Puma servers using the following non-default config are affected: ```ruby set_remote_address proxy_protocol: :v1 ```
Patches Users should upgrade to versions 7.2.1 or 8.0.2.
Workarounds - Disable PROXY protocol v1 parsing if it is not required: ```ruby
remove/comment this:
set_remote_address…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-qpgp-93vx-g8v8
- Revision 2 · amended ·
Amended from ghsa record GHSA-qpgp-93vx-g8v8
- Revision 1 · created ·
Published from ghsa record GHSA-qpgp-93vx-g8v8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47736 Advisory: Puma PROXY Protocol v1 Parser Allows Remote Memory Exhaustion IDs: CVE-2026-47736, GHSA-qpgp-93vx-g8v8 Record: https://patchnext.com/advisories/cve-2026-47736 (revision 3, source checked 3 Nov 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: puma 8.0.2, 7.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems puma: affected >= 8.0.0, < 8.0.2; >= 5.5.0, < 7.2.1; fixed in 8.0.2, 7.2.1 ## Suggested inspection (read-only) - RubyGems puma: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on puma. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qpgp-93vx-g8v8 (GitHub-reviewed advisory GHSA-qpgp-93vx-g8v8 lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1) - Verified: https://osv.dev/vulnerability/GHSA-qpgp-93vx-g8v8 (OSV record GHSA-qpgp-93vx-g8v8 lists affected ranges: RubyGems puma >=8.0.0 =5.5.0 <7.2.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…