Skip to content

← Actionable
Unrated

Twig: Sandbox: multiple __toString() policy bypasses via unguarded string coercion points

CVE-2026-47732GHSA-pr2w-4gpj-cpq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist twig/twig

    Affected
    <= 3.25.0
    Fixed in
    3.26.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-47732: 0.40% estimated exploitation activity in the next 30 days; percentile 34.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description SandboxNodeVisitor enforces SecurityPolicy::checkMethodAllowed() for implicit toString() calls by wrapping selected AST nodes in CheckToStringNode. The set of wrapped nodes is incomplete, and several Twig language constructs still trigger PHP string coercion on a Stringable operand without first consulting the policy. A sandboxed template author can therefore invoke toString() on any object reachable in the render context, even when toString on its class is not allowlisted. Confirmed bypass vectors: - Conditional expressions (a ? b : c, a ?: b, a ?? b) used as the input of a string-coercing filter or as a filter/function argument. - The matches operator and the loose comparison operators (==, !=, <, , <=, =, <=), which coerce a Stringable operand to string and can be used as an oracle to recover the value byte by byte (no tag, filter or function needs to be allowlisted). - Twig tests in general (which were never policy-gated), in particular is empty which casts a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pr2w-4gpj-cpq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47732

Advisory: Twig: Sandbox: multiple `__toString()` policy bypasses via unguarded string coercion points
IDs: CVE-2026-47732, GHSA-pr2w-4gpj-cpq4
Record: https://patchnext.com/advisories/cve-2026-47732 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist twig/twig: affected <= 3.25.0; fixed in 3.26.0

## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pr2w-4gpj-cpq4 (GitHub-reviewed advisory GHSA-pr2w-4gpj-cpq4 lists affected ranges: Packagist twig/twig >=0 <=3.25.0)

Commands are suggestions: review each one before running it.

Loading voting…