Skip to content

← Actionable
Medium, CVSS 6.3amended

FUXA's scheduler API missing admin check enables operator-to-admin escalation via scheduled device actions

CVE-2026-47721GHSA-8ghr-w65f-j3qr

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fuxa-server

    Affected
    <= 1.1.14-1243
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-47721: 0.43% estimated exploitation activity in the next 30 days; percentile 37.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authorization issue in the Scheduler API allowed authenticated non-admin users to create or modify scheduled actions that should be restricted to administrators. Details The Scheduler API did not correctly enforce administrator permissions when processing scheduler modifications. As a result, authenticated users with non-administrative roles could create or modify scheduled actions that execute privileged operations, including device value changes and server-side script execution. The issue was fixed in version 1.3.2 by enforcing the appropriate permission checks for scheduler modifications. Impact An operator-level user in FUXA reaches the PLC-write and server-side-script-execution surface that the platform otherwise restricts to administrators. In a SCADA deployment those two privileges cover setpoint control and the automation scripting engine. Alice schedules a job that rewrites a pump's enable tag, opens a safety interlock, or runs a project script that walks the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8ghr-w65f-j3qr

  2. Revision 1 · created ·

    Published from osv record GHSA-8ghr-w65f-j3qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47721

Advisory: FUXA's scheduler API missing admin check enables operator-to-admin escalation via scheduled device actions
IDs: CVE-2026-47721, GHSA-8ghr-w65f-j3qr
Record: https://patchnext.com/advisories/cve-2026-47721 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected <= 1.1.14-1243

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8ghr-w65f-j3qr (OSV record GHSA-8ghr-w65f-j3qr lists affected ranges: npm fuxa-server >=0 <=1.1.14-1243)
- Verified: https://github.com/advisories/GHSA-8ghr-w65f-j3qr (GitHub-reviewed advisory GHSA-8ghr-w65f-j3qr lists affected ranges: npm fuxa-server >=0 <=1.1.14-1243)

Commands are suggestions: review each one before running it.

Loading voting…