Skip to content

← Actionable
Medium, CVSS 5.5amended

FUXA provides guest and invalid-token access to protected read APIs in secure mode

CVE-2026-47718GHSA-r9g5-7q8j-958c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fuxa-server

    Affected
    >= 1.3.0-2773, <= 1.3.0-2773
    Fixed in
    1.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-47718: 0.46% estimated exploitation activity in the next 30 days; percentile 39.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When secureEnabled=true, FUXA 1.3.0-2773 still allows guest and invalid-token requests to read project, alarms, and scheduler APIs.

Details In secure mode, requests with no token or an explicitly invalid token were still able to access protected read endpoints. Confirmed behavior: - guest GET /api/project returned 200 OK - invalid-token requests to /api/project also returned successful responses containing project data - guest and invalid-token requests also returned 200 OK on: - /api/alarms - /api/scheduler Relevant code paths identified during analysis: - server/api/jwt-helper.js - verifyToken() converts missing-token or invalid-token states into guest context instead of rejecting the request - server/api/projects/index.js - server/api/alarms/index.js - server/api/scheduler/index.js These handlers accepted the guest context and returned sensitive data in secure mode.

PoC Tested only against isolated local lab instances under the original tester's control. No…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r9g5-7q8j-958c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r9g5-7q8j-958c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47718

Advisory: FUXA provides guest and invalid-token access to protected read APIs in secure mode
IDs: CVE-2026-47718, GHSA-r9g5-7q8j-958c
Record: https://patchnext.com/advisories/cve-2026-47718 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected >= 1.3.0-2773, <= 1.3.0-2773; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r9g5-7q8j-958c (OSV record GHSA-r9g5-7q8j-958c lists affected ranges: npm fuxa-server >=1.3.0-2773 <1.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r9g5-7q8j-958c (GitHub-reviewed advisory GHSA-r9g5-7q8j-958c lists affected ranges: npm fuxa-server >=1.3.0-2773 <=1.3.0-2773)

Commands are suggestions: review each one before running it.

Loading voting…