Strawberry GraphQL has a Circular Fragment Reference DOS
CVE-2026-47706GHSA-qfwv-87qj-98xq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (strawberry-graphql 0.315.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI strawberry-graphql
- Affected
- >= 0.71.0, <= 0.315.6
- Fixed in
- 0.315.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qfwv-87qj-98xq lists affected ranges: PyPI strawberry-graphql >=0.71.0 <0.315.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qfwv-87qj-98xq lists affected ranges: PyPI strawberry-graphql >=0.71.0 <=0.315.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-47706: 0.30% estimated exploitation activity in the next 30 days; percentile 22.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The QueryDepthLimiter extension is vulnerable to an Application-level DOS due to a lack of cycle detection in fragment spreads. When a query contains circular fragment references the determinedepth function enters an infinite recursion, leading to a RecursionError and crashing the validation process. Details The determinedepth function in querydepthlimiter.py recursively resolves FragmentSpreadNode without maintaining a set of visited fragments. By submitting a query with circular fragment references (e.g., Fragment A $\rightarrow$ Fragment B $\rightarrow$ Fragment A), the validator enters an infinite recursion. PoC server code exploit Impact Since the validation happens before execution, an attacker can cheaply trigger this recursion error to exhaust server CPU cycles and thread/worker pools
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qfwv-87qj-98xq
- Revision 1 · created ·
Published from osv record GHSA-qfwv-87qj-98xq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47706 Advisory: Strawberry GraphQL has a Circular Fragment Reference DOS IDs: CVE-2026-47706, GHSA-qfwv-87qj-98xq Record: https://patchnext.com/advisories/cve-2026-47706 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: strawberry-graphql 0.315.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI strawberry-graphql: affected >= 0.71.0, <= 0.315.6; fixed in 0.315.7 ## Suggested inspection (read-only) - `python -m pip show strawberry-graphql`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on strawberry-graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qfwv-87qj-98xq (OSV record GHSA-qfwv-87qj-98xq lists affected ranges: PyPI strawberry-graphql >=0.71.0 <0.315.7 (fixed)) - Verified: https://github.com/advisories/GHSA-qfwv-87qj-98xq (GitHub-reviewed advisory GHSA-qfwv-87qj-98xq lists affected ranges: PyPI strawberry-graphql >=0.71.0 <=0.315.6) Commands are suggestions: review each one before running it.
Loading voting…