vm2's bufferAllocLimit cap bypassed by Buffer.concat and Buffer.from arrayLike
CVE-2026-47683GHSA-gmc2-2x9w-cgh9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.5
- Fixed in
- 3.11.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gmc2-2x9w-cgh9 lists affected ranges: npm vm2 >=0 <=3.11.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47683: 0.54% estimated exploitation activity in the next 30 days; percentile 45.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary vm2 bufferAllocLimit cap bypassed by Buffer.concat and Buffer.from arrayLike The bufferAllocLimit option introduced in 3.11.0 (GHSA-6785-pvv7-mvg7) caps host-side Buffer allocations driven by sandbox code, the way embedders opt into timeout. The cap wraps Buffer.alloc, Buffer.allocUnsafe, Buffer.allocUnsafeSlow, and the deprecated Buffer(N) / new Buffer(N) forms. Two other API paths reach the same host C++ allocator with an attacker-controlled size and are not capped: Buffer.concat(list, totalLength) and Buffer.from(arrayLike) with a fake length. Sandbox code can use either to allocate an arbitrary number of host external bytes in a single call, defeating the explicit DoS mitigation the embedder configured. Details lib/setup-sandbox.js installs checkBufferAllocLimit at every wrapped entry to host Buffer allocation: - alloc() at lib/setup-sandbox.js:474 and the connect(alloc, host.Buffer.alloc) at line 480. - allocUnsafe() at line 488 and connect(allocUnsafe,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gmc2-2x9w-cgh9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47683 Advisory: vm2's bufferAllocLimit cap bypassed by Buffer.concat and Buffer.from arrayLike IDs: CVE-2026-47683, GHSA-gmc2-2x9w-cgh9 Record: https://patchnext.com/advisories/cve-2026-47683 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.5; fixed in 3.11.6 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gmc2-2x9w-cgh9 (GitHub-reviewed advisory GHSA-gmc2-2x9w-cgh9 lists affected ranges: npm vm2 >=0 <=3.11.5) Commands are suggestions: review each one before running it.
Loading voting…