Authenticated Remote Code Execution via loadReader functionName code injection in DbGate
CVE-2026-47670GHSA-wm5r-5qp3-5vxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbgate-api 7.1.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dbgate-api
- Affected
- <= 7.1.8
- Fixed in
- 7.1.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm5r-5qp3-5vxf lists affected ranges: npm dbgate-api >=0 <=7.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wm5r-5qp3-5vxf lists affected ranges: npm dbgate-api >=0 <7.1.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-47670: 1.76% estimated exploitation activity in the next 30 days; percentile 77.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary DbGate is vulnerable to authenticated Remote Code Execution (RCE). Any user with valid DbGate credentials can execute arbitrary OS commands as root by exploiting an unsanitized functionName parameter in the /runners/load-reader endpoint. The require = null mitigation is trivially bypassed via dynamic import(). <br/ Details Code injection via functionName in loadReader The /runners/load-reader endpoint interpolates the functionName parameter directly into a dynamically generated JavaScript script template without any sanitization: By injecting a newline character into functionName, an attacker breaks out of the template expression and injects arbitrary JavaScript code. The injected code uses await import('childprocess') to bypass the require = null mitigation (since import() is a language keyword, not a function that can be nullified), achieving arbitrary command execution as the process user (root in Docker). The June 2025 security fix (commit cf3f95c) added require = null to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-wm5r-5qp3-5vxf
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-wm5r-5qp3-5vxf
- Revision 1 · created ·
Published from ghsa record GHSA-wm5r-5qp3-5vxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47670 Advisory: Authenticated Remote Code Execution via loadReader functionName code injection in DbGate IDs: CVE-2026-47670, GHSA-wm5r-5qp3-5vxf Record: https://patchnext.com/advisories/cve-2026-47670 (revision 4, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dbgate-api 7.1.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dbgate-api: affected <= 7.1.8; fixed in 7.1.9 ## Suggested inspection (read-only) - `npm ls dbgate-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dbgate-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wm5r-5qp3-5vxf (GitHub-reviewed advisory GHSA-wm5r-5qp3-5vxf lists affected ranges: npm dbgate-api >=0 <=7.1.8) - Verified: https://osv.dev/vulnerability/GHSA-wm5r-5qp3-5vxf (OSV record GHSA-wm5r-5qp3-5vxf lists affected ranges: npm dbgate-api >=0 <7.1.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…