Skip to content

← Actionable
Critical, CVSS 10.0amended

DbGate: Unauthenticated Remote Code Execution via JSON Script Runner

CVE-2026-47668GHSA-8v3q-9vmx-36vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbgate-serve 7.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-47668: 3.88% estimated exploitation activity in the next 30 days; percentile 90.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary DbGate's JSON script runner (POST /runners/start) allows remote code execution via code injection in the functionName parameter of JSON script assign commands. The functionName value is interpolated directly into dynamically generated JavaScript source code via string concatenation. The generated code is then executed in a forked Node.js child process. Details Step 1: User Input Entry Point File: packages/api/src/controllers/runners.js - start() method The /runners/start endpoint accepts a POST body containing a script object. When script.type == 'json', the request follows a different code path than raw shell scripts: This path skips: 1. The run-shell-script permission check 2. The allowShellScripting platform-level check The only validation performed is checkSecureDirectoriesInScript(), which props.fileName values --- Step 2: JSON-to-JavaScript Conversion (Injection Point) File: packages/tools/src/ScriptWriter.ts - assignCore() method The JSON script's commands array…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8v3q-9vmx-36vc

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8v3q-9vmx-36vc

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8v3q-9vmx-36vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47668

Advisory: DbGate: Unauthenticated Remote Code Execution via JSON Script Runner
IDs: CVE-2026-47668, GHSA-8v3q-9vmx-36vc
Record: https://patchnext.com/advisories/cve-2026-47668 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbgate-serve 7.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dbgate-serve: affected <= 7.1.8; fixed in 7.1.9

## Suggested inspection (read-only)
- `npm ls dbgate-serve --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbgate-serve.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8v3q-9vmx-36vc (GitHub-reviewed advisory GHSA-8v3q-9vmx-36vc lists affected ranges: npm dbgate-serve >=0 <=7.1.8)
- Verified: https://osv.dev/vulnerability/GHSA-8v3q-9vmx-36vc (OSV record GHSA-8v3q-9vmx-36vc lists affected ranges: npm dbgate-serve >=0 <7.1.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…