When Vitest UI server is listening, arbitrary file can be read and executed
CVE-2026-47429GHSA-5xrq-8626-4rwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vitest 4.1.0, 3.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vitest
- Affected
- >= 4.0.0, < 4.1.0< 3.2.6
- Fixed in
- 3.2.6, 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xrq-8626-4rwp lists affected ranges: npm vitest >=4.0.0 =0 <3.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5xrq-8626-4rwp lists affected ranges: npm vitest >=4.0.0 =0 <3.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-47429: 1.03% estimated exploitation activity in the next 30 days; percentile 63.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Arbitrary file can be read on Windows when Vitest UI server is listening, especially when exposed to the network. Impact Only users that match either of the following conditions are affected: - explicitly exposes the Vitest UI server to the network (using --api.host or api.host config option) - running the Vitest UI or Browser Mode on Windows Details The API handler for /vitestattachment uses the deprecated isFileServingAllowed incorrectly. https://github.com/vitest-dev/vitest/blob/eb1abf08573032a532015b999ad3501c5e89e3bb/packages/ui/node/index.ts#L77 The function expects the passed value to use cleanUrl after the check before file system related operation. Because of this, it is possible to bypass the check by \\?\\..\\. This is not possible on Linux as Linux errors if a directory named ? does not exist. A similar problem exists in other places as well. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5xrq-8626-4rwp
- Revision 2 · amended ·
Amended from osv record GHSA-5xrq-8626-4rwp
- Revision 1 · created ·
Published from ghsa record GHSA-5xrq-8626-4rwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47429 Advisory: When Vitest UI server is listening, arbitrary file can be read and executed IDs: CVE-2026-47429, GHSA-5xrq-8626-4rwp Record: https://patchnext.com/advisories/cve-2026-47429 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vitest 4.1.0, 3.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vitest: affected >= 4.0.0, < 4.1.0; < 3.2.6; fixed in 3.2.6, 4.1.0 ## Suggested inspection (read-only) - `npm ls vitest --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vitest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5xrq-8626-4rwp (GitHub-reviewed advisory GHSA-5xrq-8626-4rwp lists affected ranges: npm vitest >=4.0.0 =0 <3.2.6) - Verified: https://osv.dev/vulnerability/GHSA-5xrq-8626-4rwp (OSV record GHSA-5xrq-8626-4rwp lists affected ranges: npm vitest >=4.0.0 =0 <3.2.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…