Skip to content

← Actionable
High, CVSS 7.1amended

OpenAM OAuth Client Impersonation via JWKS Resolver Cache

CVE-2026-47426GHSA-f2cx-463q-7m2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-oauth2 16.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-47426: 0.55% estimated exploitation activity in the next 30 days; percentile 46.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Description An Improper Authentication (CWE-287) issue in OpenAM's OAuth2 private_key_jwt client authentication path allows any registered OAuth2 client to mint tokens in the name of any other client whose key is published via a jwks_uri, without knowing the victim's signing key. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.

Impact OpenAM Community Edition deployments through version 16.0.6 that have OAuth2 clients configured for private_key_jwt authentication with keys published via jwks_uri are potentially affected. An attacker holding any such client registration, their own, or one obtained through open dynamic client registration where enabled, can mint access tokens in any other such client's name, in any realm hosted by the OpenAM process.

Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-f2cx-463q-7m2c

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2cx-463q-7m2c

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f2cx-463q-7m2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47426

Advisory: OpenAM OAuth Client Impersonation via JWKS Resolver Cache
IDs: CVE-2026-47426, GHSA-f2cx-463q-7m2c
Record: https://patchnext.com/advisories/cve-2026-47426 (revision 3, source checked 29 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-oauth2 16.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openidentityplatform.openam:openam-oauth2: affected < 16.1.1; fixed in 16.1.1

## Suggested inspection (read-only)
- Maven org.openidentityplatform.openam:openam-oauth2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openidentityplatform.openam:openam-oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f2cx-463q-7m2c (GitHub-reviewed advisory GHSA-f2cx-463q-7m2c lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <=16.0.6)
- Verified: https://osv.dev/vulnerability/GHSA-f2cx-463q-7m2c (OSV record GHSA-f2cx-463q-7m2c lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <16.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…