Skip to content

← Actionable
Medium, CVSS 6.3amended

rattler has an entry-point path traversal in noarch:python install (arbitrary file write)

CVE-2026-47425GHSA-q53q-5r4j-5729

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (py-rattler 0.24.0; rattler 0.43.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI py-rattler

    Affected
    <= 0.23.2
    Fixed in
    0.24.0
  • crates.io rattler

    Affected
    < 0.43.2
    Fixed in
    0.43.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-47425: 0.20% estimated exploitation activity in the next 30 days; percentile 9.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary EntryPoint::FromStr in rattlercondatypes performs only .trim() on the command field before the linker joins it onto the install prefix and writes an executable Python script. A malicious noarch:python package can ship an info/link.json with an entry-point name containing .., /, \, or an absolute path; the resulting file is written outside the prefix (or clobbers an existing in-prefix entry-point such as bin/pip) with mode 0o775 on Unix and a copied launcher .exe on Windows. This affects the default install path of pixi install, rattler-build, some methods in py-rattler, and any other consumer of the rattler install crate; no flag or post-link-script opt-in is involved. Resolved in https://github.com/conda/rattler/pull/2445, released in rattler 0.43.2. Affected - Repository: https://github.com/conda/rattler - Commit: a0e61a33da8b9d6de712fab2a879fa9da977e6e3 (HEAD at audit time, 2026-05-13 release) - Downstream consumers reached through the same code path: prefix-dev/pixi @…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q53q-5r4j-5729

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q53q-5r4j-5729

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47425

Advisory: rattler has an entry-point path traversal in noarch:python install (arbitrary file write)
IDs: CVE-2026-47425, GHSA-q53q-5r4j-5729
Record: https://patchnext.com/advisories/cve-2026-47425 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: py-rattler 0.24.0; rattler 0.43.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI py-rattler: affected <= 0.23.2; fixed in 0.24.0
- crates.io rattler: affected < 0.43.2; fixed in 0.43.2

## Suggested inspection (read-only)
- `python -m pip show py-rattler`: prints the installed version. Run with the environment that serves production active.
- crates.io rattler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on py-rattler, rattler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q53q-5r4j-5729 (OSV record GHSA-q53q-5r4j-5729 lists affected ranges: crates.io rattler >=0 =0 <0.24.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q53q-5r4j-5729 (GitHub-reviewed advisory GHSA-q53q-5r4j-5729 lists affected ranges: crates.io rattler >=0 =0 <=0.23.2)

Commands are suggestions: review each one before running it.

Loading voting…