Skip to content

← Actionable
High, CVSS 8.1amended

praisonai-platform: Comment endpoints accept any issue_id without workspace ownership check, cross-workspace comment read and post IDOR

CVE-2026-47417GHSA-cp4f-5m9r-5jc2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai-platform 0.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-47417: 0.36% estimated exploitation activity in the next 30 days; percentile 30.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Type: Insecure Direct Object Reference. The comment endpoints (POST /workspaces/{workspaceid}/issues/{issueid}/comments and GET .../comments) gate access on requireworkspacemember(workspaceid) only, then call CommentService.create(issueid=issueid, ...) and CommentService.listforissue(issueid) without verifying that issueid belongs to workspaceid. A user who is a member of any workspace W1 can read every comment on, and post new comments to, any issue in any other workspace W2. File: src/praisonai-platform/praisonaiplatform/api/routes/issues.py, lines 143-171; src/praisonai-platform/praisonaiplatform/services/commentservice.py, lines 19-53. Root cause: the route extracts workspaceid from the URL path and uses it solely for the membership gate, then passes the URL-supplied issueid straight into CommentService without confirming that this issue exists in workspaceid. CommentService.listforissue(issueid) runs SELECT FROM comments WHERE issueid = :issueid with no workspace join.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cp4f-5m9r-5jc2

  2. Revision 1 · created ·

    Published from osv record GHSA-cp4f-5m9r-5jc2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47417

Advisory: praisonai-platform: Comment endpoints accept any issue_id without workspace ownership check, cross-workspace comment read and post IDOR
IDs: CVE-2026-47417, GHSA-cp4f-5m9r-5jc2
Record: https://patchnext.com/advisories/cve-2026-47417 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai-platform 0.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai-platform: affected < 0.1.4; fixed in 0.1.4

## Suggested inspection (read-only)
- `python -m pip show praisonai-platform`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai-platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cp4f-5m9r-5jc2 (OSV record GHSA-cp4f-5m9r-5jc2 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cp4f-5m9r-5jc2 (GitHub-reviewed advisory GHSA-cp4f-5m9r-5jc2 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4)

Commands are suggestions: review each one before running it.

Loading voting…