Skip to content

← Actionable
Critical, CVSS 9.6amended

praisonai-platform: Any workspace member can promote themselves or others to owner via PATCH /workspaces/{id}/members/{user_id}

CVE-2026-47416GHSA-c2m8-4gcg-v22g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai-platform 0.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-47416: 0.26% estimated exploitation activity in the next 30 days; percentile 18.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Type: Vertical privilege escalation. The PATCH /workspaces/{workspaceid}/members/{userid} endpoint is gated by requireworkspacemember(workspaceid), which defaults to minrole="member" and is never overridden by the route. The handler then calls MemberService.updaterole(workspaceid, userid, body.role) which sets the target member's role to whatever the request body specifies, with no check that the caller has owner-or-admin privilege, no check that the new role is not higher than the caller's own, and no check that the caller is not silently promoting themselves. File: src/praisonai-platform/praisonaiplatform/api/routes/workspaces.py, lines 115-127; services/memberservice.py, lines 55-69; api/deps.py, lines 54-73. Root cause: requireworkspacemember exists with a minrole parameter (deps.py:58) but FastAPI's Depends(requireworkspacemember) cannot pass arguments, so every route uses the default "member". The route then passes the URL-supplied userid and the body-supplied role…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c2m8-4gcg-v22g

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c2m8-4gcg-v22g

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c2m8-4gcg-v22g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47416

Advisory: praisonai-platform: Any workspace member can promote themselves or others to owner via PATCH /workspaces/{id}/members/{user_id}
IDs: CVE-2026-47416, GHSA-c2m8-4gcg-v22g
Record: https://patchnext.com/advisories/cve-2026-47416 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai-platform 0.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai-platform: affected <= 0.1.2; fixed in 0.1.4

## Suggested inspection (read-only)
- `python -m pip show praisonai-platform`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai-platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2m8-4gcg-v22g (GitHub-reviewed advisory GHSA-c2m8-4gcg-v22g lists affected ranges: PyPI praisonai-platform >=0 <=0.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-c2m8-4gcg-v22g (OSV record GHSA-c2m8-4gcg-v22g lists affected ranges: PyPI praisonai-platform >=0 <0.1.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…