praisonai-platform: Any workspace member can delete the entire workspace via DELETE /workspaces/{id}
CVE-2026-47412GHSA-g8rr-7rj2-f627
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai-platform 0.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai-platform
- Affected
- < 0.1.4
- Fixed in
- 0.1.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g8rr-7rj2-f627 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8rr-7rj2-f627 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-47412: 0.53% estimated exploitation activity in the next 30 days; percentile 44.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Type: Authorization bypass enabling destructive action. The DELETE /workspaces/{workspaceid} endpoint is gated only by requireworkspacemember(workspaceid) (default minrole="member"). Any member of the workspace can issue a single DELETE to wipe the entire workspace, including every project, issue, comment, agent, label, and member record (cascading via the foreign-key relationships). There is no owner-role gate, no confirmation token, no soft-delete window, no recovery path. File: src/praisonai-platform/praisonaiplatform/api/routes/workspaces.py, lines 77-86; services/workspaceservice.py's delete() method. Root cause: the route uses Depends(requireworkspacemember) which defaults to minrole="member" and is never overridden. The service method WorkspaceService.delete(workspaceid) performs the destructive operation without any caller-permission verification. The role hierarchy (MemberService.hasrole, memberservice.py:80-96) is implemented but unused for this endpoint. Affected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g8rr-7rj2-f627
- Revision 1 · created ·
Published from osv record GHSA-g8rr-7rj2-f627
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47412
Advisory: praisonai-platform: Any workspace member can delete the entire workspace via DELETE /workspaces/{id}
IDs: CVE-2026-47412, GHSA-g8rr-7rj2-f627
Record: https://patchnext.com/advisories/cve-2026-47412 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai-platform 0.1.4. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI praisonai-platform: affected < 0.1.4; fixed in 0.1.4
## Suggested inspection (read-only)
- `python -m pip show praisonai-platform`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai-platform.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g8rr-7rj2-f627 (OSV record GHSA-g8rr-7rj2-f627 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g8rr-7rj2-f627 (GitHub-reviewed advisory GHSA-g8rr-7rj2-f627 lists affected ranges: PyPI praisonai-platform >=0 <0.1.4)
Commands are suggestions: review each one before running it.Loading voting…