Skip to content

← Actionable
High, CVSS 8.1amended

PraisonAI: Arbitrary code execution via unguarded spec.loader.exec_module in agents_generator.py - sibling of CVE-2026-44334

CVE-2026-47398GHSA-78r8-wwqv-r299

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.39
    Fixed in
    4.6.40

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-47398: 0.50% estimated exploitation activity in the next 30 days; percentile 42.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-64824: 0.71% estimated exploitation activity in the next 30 days; percentile 53.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

<html<head</head<body<h2Arbitrary code execution via ungated <codespec.loader.execmodule</code in <codeagentsgenerator.py</code (v4.6.32 chokepoint refactor bypass)</h2 <h3Summary</h3 <pThe v4.6.32 chokepoint refactor (which patched CVE-2026-44334 / GHSA-xcmw-grxf-wjhj) added the <codePRAISONAIALLOWLOCALTOOLS</code env-var gate to the <codetooloverride.py</code sinks. However, <strongtwo additional <codespec.loader.execmodule</code call sites</strong in <codepraisonai/agentsgenerator.py</code were missed and remain completely unguarded on current <codemaster</code (v4.6.37). Both functions accept a <codemodulepath</code parameter sourced from YAML configuration and execute it without validation, signature checking, or the env-var gate.</p <h3Patch lineage</h3 CVE | GHSA | Fixed in | What was patched -- | -- | -- | -- CVE-2026-40156 | GHSA-2g3w-cpc4-chr4 | 4.5.128 | CWD tools.py auto-load in toolresolver.py CVE-2026-40287 | GHSA-g985-wjh9-qxxc | 4.5.139 | Env-var gate added to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-78r8-wwqv-r299

  2. Revision 1 · created ·

    Published from osv record GHSA-78r8-wwqv-r299

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47398

Advisory: PraisonAI: Arbitrary code execution via unguarded `spec.loader.exec_module` in `agents_generator.py` - sibling of CVE-2026-44334
IDs: CVE-2026-47398, GHSA-78r8-wwqv-r299
Record: https://patchnext.com/advisories/cve-2026-47398 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.39; fixed in 4.6.40

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78r8-wwqv-r299 (OSV record GHSA-78r8-wwqv-r299 lists affected ranges: PyPI praisonai >=0 <4.6.40 (fixed))
- Verified: https://github.com/advisories/GHSA-78r8-wwqv-r299 (GitHub-reviewed advisory GHSA-78r8-wwqv-r299 lists affected ranges: PyPI praisonai >=0 <=4.6.39)

Commands are suggestions: review each one before running it.

Loading voting…