Skip to content

← Actionable
Critical, CVSS 9.8amended

PraisonAI deploy --type api emits a Flask server with authentication disabled by default

CVE-2026-47393GHSA-8444-4fhq-fxpq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.39
    Fixed in
    4.6.40

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-47393: 0.58% estimated exploitation activity in the next 30 days; percentile 47.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CVE-2026-44338 (GHSA-6rmh-7xcm-cpxj) documents that PraisonAI ships a code-generator (praisonai.deploy.api.generateapiservercode) that emits a Flask API server with authentication disabled by default. Users who follow the documented quickstart (praisonai deploy --type api) get a server that: - binds to 0.0.0.0 per the recommended sample YAML - exposes /chat and /agents endpoints - runs praisonai.run() on user-supplied JSON input — LLM orchestration with the API key materials present in the process environment - does not require any authentication The PyPI wheel praisonai==4.6.33 (current @latest) still ships the generator with authenabled defaulting to False. The fix shape is opt-in via APIConfig(authenabled=True, authtoken=...). Details Anchor (file:line:symbol) - Vulnerable artifact: praisonai==4.6.33 on PyPI. - Defaults: praisonai/deploy/models.py:29 — authenabled: bool = Field(default=False, ...); praisonai/deploy/models.py:30 — authtoken: Optional[str] =…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8444-4fhq-fxpq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8444-4fhq-fxpq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8444-4fhq-fxpq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47393

Advisory: PraisonAI `deploy --type api` emits a Flask server with authentication disabled by default
IDs: CVE-2026-47393, GHSA-8444-4fhq-fxpq
Record: https://patchnext.com/advisories/cve-2026-47393 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.39; fixed in 4.6.40

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8444-4fhq-fxpq (GitHub-reviewed advisory GHSA-8444-4fhq-fxpq lists affected ranges: PyPI praisonai >=0 <=4.6.39)
- Verified: https://osv.dev/vulnerability/GHSA-8444-4fhq-fxpq (OSV record GHSA-8444-4fhq-fxpq lists affected ranges: PyPI praisonai >=0 <4.6.40 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…