Skip to content

← Actionable
Critical, CVSS 9.9amended

PraisonAI vulnerable to sandbox escape via print.__self__ builtins module leak in execute_code (subprocess mode)

CVE-2026-47392GHSA-4mr5-g6f9-cfrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.6.40; praisonai 4.6.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-47392: 0.88% estimated exploitation activity in the next 30 days; percentile 59.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary executecode() in praisonaiagents/tools/pythontools.py (v1.6.37, subprocess sandbox mode) can be fully bypassed using print.self to retrieve the real Python builtins module, from which import can be extracted via vars() and runtime string construction. This achieves arbitrary OS command execution on the host, completely defeating the sandbox. This is a novel bypass that survives all patches for CVE-2026-39888 (frame traversal), CVE-2026-34938 (str subclass), and CVE-2026-40158 (type.getattribute trampoline). --- Severity CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H — 9.9 Critical --- Root Cause Three independent gaps in the AST-based security validation: Gap 1: self missing from blockedattrs In CPython, all built-in functions (C-level functions) have a self attribute that returns the module they belong to. The built-in functions in safebuiltins (print, len, range, etc.) are the real CPython built-in functions, so print.self returns <module 'builtins' (built-in). The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4mr5-g6f9-cfrh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4mr5-g6f9-cfrh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4mr5-g6f9-cfrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47392

Advisory: PraisonAI vulnerable to sandbox escape via `print.__self__` builtins module leak in `execute_code` (subprocess mode)
IDs: CVE-2026-47392, GHSA-4mr5-g6f9-cfrh
Record: https://patchnext.com/advisories/cve-2026-47392 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.6.40; praisonai 4.6.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.6.39; fixed in 1.6.40
- PyPI praisonai: affected <= 4.6.39; fixed in 4.6.40

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents, praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mr5-g6f9-cfrh (GitHub-reviewed advisory GHSA-4mr5-g6f9-cfrh lists affected ranges: PyPI praisonaiagents >=0 =0 <=4.6.39)
- Verified: https://osv.dev/vulnerability/GHSA-4mr5-g6f9-cfrh (OSV record GHSA-4mr5-g6f9-cfrh lists affected ranges: PyPI praisonaiagents >=0 =0 <4.6.40 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…