Skip to content

← Actionable
Medium, CVSS 5.5amended

PraisonAI spider_tools SSRF protection bypass via alternate loopback host encodings

CVE-2026-47390GHSA-5c6w-wwfq-7qqm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.6.40; praisonai 4.6.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-47390: 0.18% estimated exploitation activity in the next 30 days; percentile 6.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PraisonAI's spidertools URL validation can be bypassed using alternate loopback host encodings. The affected component is: The tool contains a URL validation function intended to block local or unsafe targets before fetching attacker-controlled URLs. However, the validation only blocks a small set of exact host strings such as localhost and 127.0.0.1. It does not normalize hostnames, resolve DNS, parse numeric IPv4 variants, or validate the final resolved IP address before making the request. As a result, URLs such as the following bypass the protection and still reach loopback services: After the weak validation passes, scrapepage() calls requests.Session.get() on the attacker-controlled URL. This allows an attacker who can influence URLs passed to scrapepage, crawl, or extracttext to induce SSRF requests against loopback-only services. This is a server-side request forgery protection bypass. Details The affected code is in: The vulnerable flow is: The validation appears to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5c6w-wwfq-7qqm

  2. Revision 1 · created ·

    Published from osv record GHSA-5c6w-wwfq-7qqm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47390

Advisory: PraisonAI spider_tools SSRF protection bypass via alternate loopback host encodings
IDs: CVE-2026-47390, GHSA-5c6w-wwfq-7qqm
Record: https://patchnext.com/advisories/cve-2026-47390 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.6.40; praisonai 4.6.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.6.39; fixed in 1.6.40
- PyPI praisonai: affected <= 4.6.39; fixed in 4.6.40

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents, praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5c6w-wwfq-7qqm (OSV record GHSA-5c6w-wwfq-7qqm lists affected ranges: PyPI praisonaiagents >=0 =0 <4.6.40 (fixed))
- Verified: https://github.com/advisories/GHSA-5c6w-wwfq-7qqm (GitHub-reviewed advisory GHSA-5c6w-wwfq-7qqm lists affected ranges: PyPI praisonaiagents >=0 =0 <=4.6.39)

Commands are suggestions: review each one before running it.

Loading voting…