containerd image-triggered runtime DoS via unbounded group parsing
CVE-2026-47262GHSA-jpcc-p29g-p8mq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd/v2 2.3.2, 2.2.5, 2.1.9, 2.0.10; github.com/containerd/containerd 1.7.33), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd/v2
- Affected
- >= 2.0.0, < 2.0.10>= 2.1.0, < 2.1.9>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.2
- Fixed in
- 2.0.10, 2.1.9, 2.3.2, 2.2.5
Go github.com/containerd/containerd
- Affected
- >= 1.7.0, < 1.7.33
- Fixed in
- 1.7.33
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpcc-p29g-p8mq lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =1.7.0 <1.7.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47262: 0.27% estimated exploitation activity in the next 30 days; percentile 18.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in containerd allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components. Patches This bug has been fixed in the following containerd versions: 2.3.2 2.2.5 2.1.9 2.0.10 1.7.33 Users should update to these versions to resolve the issue. Workarounds Ensure that only trusted images are used and that only trusted users have permissions to import images or schedule pods. Credits The containerd project would like to thank Jakub Ciolek (@jake-ciolek) at AlphaSense and Kyle Elliott @ Trail of Bits who independently discovered and responsibly disclosed this issue in accordance with the containerd security policy. For more information If you have any questions or comments about…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpcc-p29g-p8mq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47262 Advisory: containerd image-triggered runtime DoS via unbounded group parsing IDs: CVE-2026-47262, GHSA-jpcc-p29g-p8mq Record: https://patchnext.com/advisories/cve-2026-47262 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd/v2 2.3.2, 2.2.5, 2.1.9, 2.0.10; github.com/containerd/containerd 1.7.33. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd/v2: affected >= 2.0.0, < 2.0.10; >= 2.1.0, < 2.1.9; >= 2.2.0, < 2.2.5; >= 2.3.0, < 2.3.2; fixed in 2.0.10, 2.1.9, 2.3.2, 2.2.5 - Go github.com/containerd/containerd: affected >= 1.7.0, < 1.7.33; fixed in 1.7.33 ## Suggested inspection (read-only) - Go github.com/containerd/containerd/v2: check the installed version with your package manager. - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd/v2, github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpcc-p29g-p8mq (GitHub-reviewed advisory GHSA-jpcc-p29g-p8mq lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =1.7.0 <1.7.33) Commands are suggestions: review each one before running it.
Loading voting…