Anyquery has Path Traversal through clear_plugin_cache, Allowing Arbitrary Directory Deletion
CVE-2026-47253GHSA-j9rx-rppg-6hh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/julien040/anyquery 0.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/julien040/anyquery
- Affected
- <= 0.4.4
- Fixed in
- 0.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j9rx-rppg-6hh4 lists affected ranges: Go github.com/julien040/anyquery >=0 <=0.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-47253: 0.44% estimated exploitation activity in the next 30 days; percentile 38.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Path Traversal in clearplugincache Allows Arbitrary Directory Deletion | Field | Value | | ---------------- | ----- | | Repository | julien040/anyquery | | Affected version | 0.4.4 | | Vulnerability | CWE-22 — Improper Limitation of a Pathname to a Restricted Directory | | Severity | High | Summary The SQL scalar function clearplugincache(plugin) in namespace/otherfunctions.go passes the caller-supplied plugin argument directly to path.Join and then to os.RemoveAll, with only an empty-string check as a guard. Because path.Join silently resolves .. segments, a low-privileged bearer-token holder can submit SELECT clearplugincache('../../../../tmp/target') to the /v1/query HTTP endpoint and delete any directory reachable by the server process. In the verified scenario, a directory outside $XDGCACHEHOME/anyquery/plugins/ was successfully deleted, confirming full path-traversal exploitation. Affected Code namespace/otherfunctions.go:46 — pathlib.Join resolves .. segments in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j9rx-rppg-6hh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47253 Advisory: Anyquery has Path Traversal through `clear_plugin_cache`, Allowing Arbitrary Directory Deletion IDs: CVE-2026-47253, GHSA-j9rx-rppg-6hh4 Record: https://patchnext.com/advisories/cve-2026-47253 (revision 1, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/julien040/anyquery 0.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/julien040/anyquery: affected <= 0.4.4; fixed in 0.4.5 ## Suggested inspection (read-only) - Go github.com/julien040/anyquery: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/julien040/anyquery. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j9rx-rppg-6hh4 (GitHub-reviewed advisory GHSA-j9rx-rppg-6hh4 lists affected ranges: Go github.com/julien040/anyquery >=0 <=0.4.4) Commands are suggestions: review each one before running it.
Loading voting…