Skip to content

← Actionable
Medium, CVSS 5.3

Netty HTTP/2: Advertised MAX_CONCURRENT_STREAMS are not enforced

CVE-2026-47244GHSA-5x3r-wrvg-rp6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http2 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-47244: 0.38% estimated exploitation activity in the next 30 days; percentile 32.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact DefaultHttp2Connection.DefaultEndpoint initialises maxActiveStreams/maxStreams to Integer.MAXVALUE, and Http2Settings never inserts SETTINGSMAXCONCURRENTSTREAMS by default (Http2Settings.java:305-307 only clamps a user-supplied value). Unless the application explicitly calls initialSettings().maxConcurrentStreams(n), a Netty HTTP/2 server advertises no limit and enforces none locally. Each open stream allocates a DefaultStream object, PropertyMap slots, flow-controller state and IntObjectHashMap entry; with ~2^30 permissible odd stream IDs a single TCP connection can create hundreds of thousands of long-lived stream objects. This is also the precondition for CVE-2023-44487-style Rapid-Reset amplification, where the absence of a low concurrent cap multiplies backend work. Resources https://www.rfc-editor.org/rfc/rfc7540.html#section-6.5.2

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5x3r-wrvg-rp6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47244

Advisory: Netty HTTP/2: Advertised MAX_CONCURRENT_STREAMS are not enforced
IDs: CVE-2026-47244, GHSA-5x3r-wrvg-rp6q
Record: https://patchnext.com/advisories/cve-2026-47244 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http2 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-codec-http2: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-codec-http2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-codec-http2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5x3r-wrvg-rp6q (GitHub-reviewed advisory GHSA-5x3r-wrvg-rp6q lists affected ranges: Maven io.netty:netty-codec-http2 >=4.2.0.Final =0 <=4.1.134.Final)

Commands are suggestions: review each one before running it.

Loading voting…