Net::IMAP: Command Injection via ID command argument
CVE-2026-47242GHSA-46q3-7gv7-qmgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net-imap 0.6.4.1, 0.5.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems net-imap
- Affected
- >= 0.6.0, <= 0.6.4<= 0.5.14
- Fixed in
- 0.6.4.1, 0.5.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46q3-7gv7-qmgg lists affected ranges: RubyGems net-imap >=0.6.0 =0 <=0.5.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47242: 0.18% estimated exploitation activity in the next 30 days; percentile 8.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Two Net::IMAP commands, #id and #enable, do not validate their arguments. Arguments to either command could be used by an attacker to inject arbitrary IMAP commands. Please note that passing untrusted inputs to these commands is usually inappropriate and expected to be uncommon. Details When Net::IMAP#id is called with a hash argument, although the ID field value strings are correctly quoted (escaping quoted specials), they were not validated to prohibit CRLF sequences. While Net::IMAP#enable does process its arguments for aliases, it does not validate them as valid atoms (or as a list of valid atoms). The #tos value is sent verbatim. Impact This is expected to impact very few users: use of untrusted user input for either command is expected to be very uncommon. The documentation for #enable explicitly warns that using any arguments that are not in the explicitly supported list may result in undocumented behavior. Using arbitrary untrusted user input for #enable will always…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-46q3-7gv7-qmgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47242 Advisory: Net::IMAP: Command Injection via ID command argument IDs: CVE-2026-47242, GHSA-46q3-7gv7-qmgg Record: https://patchnext.com/advisories/cve-2026-47242 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net-imap 0.6.4.1, 0.5.15. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems net-imap: affected >= 0.6.0, <= 0.6.4; <= 0.5.14; fixed in 0.6.4.1, 0.5.15 ## Suggested inspection (read-only) - RubyGems net-imap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net-imap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-46q3-7gv7-qmgg (GitHub-reviewed advisory GHSA-46q3-7gv7-qmgg lists affected ranges: RubyGems net-imap >=0.6.0 =0 <=0.5.14) Commands are suggestions: review each one before running it.
Loading voting…