Net::IMAP: Command Injection via non-synchronizing literal in "raw" argument
CVE-2026-47240GHSA-8p34-64r3-mwg8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net-imap 0.6.4.1, 0.5.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems net-imap
- Affected
- >= 0.6.0, <= 0.6.4<= 0.5.14
- Fixed in
- 0.6.4.1, 0.5.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8p34-64r3-mwg8 lists affected ranges: RubyGems net-imap >=0.6.0 =0 <=0.5.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47240: 0.83% estimated exploitation activity in the next 30 days; percentile 57.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Several Net::IMAP commands accept a "raw data" argument that is sent verbatim after validation to prevent command injection. However, if a server does not support non-synchronizing literals, it may still be possible to inject arbitrary IMAP commands inside non-synchronizing literals. Details Raw data arguments support embedded literal values, both synchronizing and non-synchronizing. Non-synchronizing literals can only be safely sent when the server advertises any of the LITERAL+, LITERAL-, or IMAP4rev2 capabilities. But raw data arguments do not verify server support for non-synchronizing literals prior to sending. Servers without support for non-synchronizing literals could handle them in several different ways: If a server sees a "}\r\n" byte sequence but can't parse the literal bytesize, it may cautiously decide to close the connection, blocking any command injection attacks. However, a server without support for non-synchronizing literals may instead interpret the "+}\r\n" as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8p34-64r3-mwg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47240 Advisory: Net::IMAP: Command Injection via non-synchronizing literal in "raw" argument IDs: CVE-2026-47240, GHSA-8p34-64r3-mwg8 Record: https://patchnext.com/advisories/cve-2026-47240 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net-imap 0.6.4.1, 0.5.15. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems net-imap: affected >= 0.6.0, <= 0.6.4; <= 0.5.14; fixed in 0.6.4.1, 0.5.15 ## Suggested inspection (read-only) - RubyGems net-imap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net-imap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8p34-64r3-mwg8 (GitHub-reviewed advisory GHSA-8p34-64r3-mwg8 lists affected ranges: RubyGems net-imap >=0.6.0 =0 <=0.5.14) Commands are suggestions: review each one before running it.
Loading voting…