Skip to content

← Actionable
Low, CVSS 2.1amended

kas's late signature validation may allow unnoticed repository manipulations

CVE-2026-47192GHSA-4vqc-wpwg-vh7j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kas 5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI kas

    Affected
    >= 4.8, < 5.3
    Fixed in
    5.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-47192: 0.25% estimated exploitation activity in the next 30 days; percentile 17.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact So far, kas checks out and processes repositories regarding configuration includes prior to validating signatures of those repositories. This may allow to replace on original repository with one under the control of an attacker under very specific conditions. First of all, the attacker must have gained control of a repository that a kas file of the victim is referencing. Furthermore, the following conditions must be fulfilled: - the victim's kas configuration must include a configuration file from the attacked repository - the repository state is referenced by tag, and no commit ID is specified (this is triggering a warning, though) - the key used for validating the tag or commit signature is stored as file in a repository - no fingerprint for the key is specified - the sourcedir key must not be set by the victim when calling kas (e.g. by avoiding a local .config.yaml) Given these conditions, the attacker could modify the included kas configuration in way that the key used to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4vqc-wpwg-vh7j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4vqc-wpwg-vh7j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47192

Advisory: kas's late signature validation may allow unnoticed repository manipulations
IDs: CVE-2026-47192, GHSA-4vqc-wpwg-vh7j
Record: https://patchnext.com/advisories/cve-2026-47192 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kas 5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI kas: affected >= 4.8, < 5.3; fixed in 5.3

## Suggested inspection (read-only)
- `python -m pip show kas`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vqc-wpwg-vh7j (OSV record GHSA-4vqc-wpwg-vh7j lists affected ranges: PyPI kas >=4.8 <5.3 (fixed))
- Verified: https://github.com/advisories/GHSA-4vqc-wpwg-vh7j (GitHub-reviewed advisory GHSA-4vqc-wpwg-vh7j lists affected ranges: PyPI kas >=4.8 <5.3)

Commands are suggestions: review each one before running it.

Loading voting…