MantisBT: SOAP API Authentication Bypass with Privilege Escalation to Administrator
CVE-2026-47156GHSA-c2xg-qjqw-2v98
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.28.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mantisbt/mantisbt
- Affected
- <= 2.28.3
- Fixed in
- 2.28.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c2xg-qjqw-2v98 lists affected ranges: Packagist mantisbt/mantisbt >=0 <=2.28.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47156: 0.69% estimated exploitation activity in the next 30 days; percentile 52.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MantisBT 2.28.3 and earlier contains a critical authentication bypass in the SOAP API's mcichecklogin() function. Any user knowing any valid cookiestring can authenticate as any other user (knowing their username), including the administrator, without knowing the target's password. The vulnerability is exploitable with zero prior access on default MantisBT installations because self-registration is enabled by default ($gallowsignup = ON). A self-registered user can use their own cookiestring (readable from their browser's MANTISSTRINGCOOKIE cookie after login) to impersonate the administrator via the SOAP API. The REST API is NOT affected. The REST API's AuthMiddleware derives the username server-side from the API token or session cookie, so the username cannot be spoofed. The Web UI is NOT affected. The Web UI authenticates via PHP session cookies (PHPSESSID) and validates the MANTISSTRINGCOOKIE against the logged-in user through authiscookievalid(). The username is derived…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c2xg-qjqw-2v98
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47156 Advisory: MantisBT: SOAP API Authentication Bypass with Privilege Escalation to Administrator IDs: CVE-2026-47156, GHSA-c2xg-qjqw-2v98 Record: https://patchnext.com/advisories/cve-2026-47156 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.28.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mantisbt/mantisbt: affected <= 2.28.3; fixed in 2.28.4 ## Suggested inspection (read-only) - Packagist mantisbt/mantisbt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mantisbt/mantisbt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c2xg-qjqw-2v98 (GitHub-reviewed advisory GHSA-c2xg-qjqw-2v98 lists affected ranges: Packagist mantisbt/mantisbt >=0 <=2.28.3) Commands are suggestions: review each one before running it.
Loading voting…