Skip to content

← Actionable
Medium, CVSS 6.5amended

vLLM's Artifact Pin Decay allows pinned deployments to load unpinned code, weights, and processors

CVE-2026-47155GHSA-3ww4-5jv9-j5gm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.22.0
    Fixed in
    0.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-47155: 0.25% estimated exploitation activity in the next 30 days; percentile 16.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vLLM's revision pinning controls do not consistently apply to all artifacts loaded for a model. A deployment that supplies --revision or --code-revision can still load dynamic code, GGUF files, image processors, retrieval side weights, or same-repository subfolder weights/config from an unpinned/default revision. This is a supply-chain integrity issue for pinned vLLM deployments. Operators can believe they are serving a reviewed model revision while vLLM resolves behavior-affecting nested or sibling artifacts outside that reviewed revision. Details The expected invariant is: When a vLLM operator supplies a model or code revision pin, every code, config, processor, weight file, side weight, and same-repository subfolder artifact loaded as part of that model should resolve under that pin unless vLLM exposes and enforces a separate explicit pin for that artifact. Current main was verified affected at commit 3795d7acf431980e62e738493f437ae2a51549da. Affected source boundaries: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3ww4-5jv9-j5gm

  2. Revision 1 · created ·

    Published from osv record GHSA-3ww4-5jv9-j5gm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47155

Advisory: vLLM's Artifact Pin Decay allows pinned deployments to load unpinned code, weights, and processors
IDs: CVE-2026-47155, GHSA-3ww4-5jv9-j5gm
Record: https://patchnext.com/advisories/cve-2026-47155 (revision 2, source checked 26 Oct 2026, 13:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3ww4-5jv9-j5gm (OSV record GHSA-3ww4-5jv9-j5gm lists affected ranges: PyPI vllm >=0 <0.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3ww4-5jv9-j5gm (GitHub-reviewed advisory GHSA-3ww4-5jv9-j5gm lists affected ranges: PyPI vllm >=0 <0.22.0)

Commands are suggestions: review each one before running it.

Loading voting…