Skip to content

← Actionable
Medium, CVSS 5.5amended

Shamefile has an arbitrary file read via shamefile.yaml in shame next

CVE-2026-47144GHSA-x6p3-76f2-xxvh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shamefile 0.1.7; shamefile 0.1.7; shamefile 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-47144: 0.18% estimated exploitation activity in the next 30 days; percentile 8.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A path traversal vulnerability in shame next allows an attacker-controlled shamefile.yaml to disclose contents of files outside the repository, one line at a time, to the terminal of a user who runs the command. See patch commit for technical details. Patches Fixed in 0.1.7. Upgrade to either 0.1.7 or later versions to incorporate the patch. Workarounds Do not run shame next against untrusted shamefile.yaml. Use shame me --dry-run for CI validation. Resources - Patch commit: https://github.com/BKDDFS/shamefile/commit/77b0aeea318503582818c708518c601fedc43557 - Pull request: https://github.com/BKDDFS/shamefile/pull/80 - Release: https://github.com/BKDDFS/shamefile/releases/tag/v0.1.7 - CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x6p3-76f2-xxvh

  2. Revision 1 · created ·

    Published from osv record GHSA-x6p3-76f2-xxvh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47144

Advisory: Shamefile has an arbitrary file read via shamefile.yaml in shame next
IDs: CVE-2026-47144, GHSA-x6p3-76f2-xxvh
Record: https://patchnext.com/advisories/cve-2026-47144 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shamefile 0.1.7; shamefile 0.1.7; shamefile 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI shamefile: affected <= 0.1.6; fixed in 0.1.7
- crates.io shamefile: affected <= 0.1.6; fixed in 0.1.7
- npm shamefile: affected <= 0.1.6; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show shamefile`: prints the installed version. Run with the environment that serves production active.
- crates.io shamefile: check the installed version with your package manager.
- `npm ls shamefile --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shamefile.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x6p3-76f2-xxvh (OSV record GHSA-x6p3-76f2-xxvh lists affected ranges: PyPI shamefile >=0 =0 =0 <0.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-x6p3-76f2-xxvh (GitHub-reviewed advisory GHSA-x6p3-76f2-xxvh lists affected ranges: PyPI shamefile >=0 =0 =0 <=0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…