Skip to content

← Actionable
Medium, CVSS 4.6amended

NodeVM observability builtins leak host process and HTTP request data

CVE-2026-47141GHSA-9g8x-92q2-p28f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.3
    Fixed in
    3.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-47141: 0.38% estimated exploitation activity in the next 30 days; percentile 32.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary NodeVM exposes some process-wide observability builtins when they are allowed through require.builtin. The following builtins are not blocked by the dangerous builtin denylist: These modules are process-wide, not sandbox-local. Sandboxed code can use them to observe host application data across the vm2 boundary. Note: It is a host data exposure issue. The impact depends on whether the host application allows these builtins and uses HTTP, async request context, diagnostics channels, or performance marks in the same process. Details Non-denied builtins are exposed to the sandbox through lib/builtin.js: diagnosticschannel, asynchooks, and perfhooks are not denied. These modules expose host process state rather than sandbox-local state. Confirmed examples: 1. diagnosticschannel lets sandboxed code subscribe to Node.js HTTP diagnostic channels such as http.server.request.start. The sandbox receives host HTTP request objects and can read headers such as Authorization or session…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9g8x-92q2-p28f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9g8x-92q2-p28f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47141

Advisory: NodeVM observability builtins leak host process and HTTP request data
IDs: CVE-2026-47141, GHSA-9g8x-92q2-p28f
Record: https://patchnext.com/advisories/cve-2026-47141 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.3; fixed in 3.11.4

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9g8x-92q2-p28f (OSV record GHSA-9g8x-92q2-p28f lists affected ranges: npm vm2 >=0 <3.11.4 (fixed))
- Verified: https://github.com/advisories/GHSA-9g8x-92q2-p28f (GitHub-reviewed advisory GHSA-9g8x-92q2-p28f lists affected ranges: npm vm2 >=0 <=3.11.3)

Commands are suggestions: review each one before running it.

Loading voting…