Skip to content

← Actionable
Critical, CVSS 10.0amended

NodeVM builtin denylist bypass via process and inspector/promises allows host code execution

CVE-2026-47140GHSA-rp36-8xq3-r6c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.3
    Fixed in
    3.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-47140: 0.98% estimated exploitation activity in the next 30 days; percentile 62.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary NodeVM blocks several dangerous Node.js builtins such as module, workerthreads, cluster, vm, repl, and inspector. However, the denylist misses process and inspector/promises. Both can be used from sandboxed code to reach host-side execution primitives. This allows sandboxed code to bypass the intended builtin restrictions and execute code in the host process. Details The dangerous builtin denylist is defined in lib/builtin.js. This list does not include: Non-denied builtins are exposed to the sandbox through: Because of this, sandboxed code can bypass the expected restrictions in two ways: 1. require('process').getBuiltinModule('childprocess') reloads childprocess, even when childprocess is excluded. 2. require('inspector/promises') exposes the Inspector protocol and can call Runtime.evaluate in the host process. PoC Tested on: Run from the vm2 repository root: dangerous-builtin-denylist-rce.js The PoC first confirms the intended restrictions work: Then it bypasses them: This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rp36-8xq3-r6c4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rp36-8xq3-r6c4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rp36-8xq3-r6c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47140

Advisory: NodeVM builtin denylist bypass via process and inspector/promises allows host code execution
IDs: CVE-2026-47140, GHSA-rp36-8xq3-r6c4
Record: https://patchnext.com/advisories/cve-2026-47140 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.3; fixed in 3.11.4

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rp36-8xq3-r6c4 (GitHub-reviewed advisory GHSA-rp36-8xq3-r6c4 lists affected ranges: npm vm2 >=0 <=3.11.3)
- Verified: https://osv.dev/vulnerability/GHSA-rp36-8xq3-r6c4 (OSV record GHSA-rp36-8xq3-r6c4 lists affected ranges: npm vm2 >=0 <3.11.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…