vm2 has a CVE-2023-37903 patch bypass: nesting:true without explicit require still allows full RCE
CVE-2026-47137GHSA-m4wx-m65x-ghrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.3
- Fixed in
- 3.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4wx-m65x-ghrr lists affected ranges: npm vm2 >=0 <=3.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m4wx-m65x-ghrr lists affected ranges: npm vm2 >=0 <3.11.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-47137: 0.38% estimated exploitation activity in the next 30 days; percentile 32.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. Root Cause Impact Full Remote Code Execution on the host system. An attacker running code inside a NodeVM({ nesting: true }) sandbox (without specifying require) can: 1. require('vm2') to get the vm2 library 2. Construct an inner NodeVM with require: { builtin: ['childprocess'] } 3. Execute arbitrary OS commands via childprocess.execSync The inner VM is completely unconstrained…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m4wx-m65x-ghrr
- Revision 2 · amended ·
Amended from osv record GHSA-m4wx-m65x-ghrr
- Revision 1 · created ·
Published from ghsa record GHSA-m4wx-m65x-ghrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47137 Advisory: vm2 has a CVE-2023-37903 patch bypass: nesting:true without explicit require still allows full RCE IDs: CVE-2026-47137, GHSA-m4wx-m65x-ghrr Record: https://patchnext.com/advisories/cve-2026-47137 (revision 3, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.3; fixed in 3.11.4 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m4wx-m65x-ghrr (GitHub-reviewed advisory GHSA-m4wx-m65x-ghrr lists affected ranges: npm vm2 >=0 <=3.11.3) - Verified: https://osv.dev/vulnerability/GHSA-m4wx-m65x-ghrr (OSV record GHSA-m4wx-m65x-ghrr lists affected ranges: npm vm2 >=0 <3.11.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…