Skip to content

← Actionable
High, CVSS 8.7amended

vm2 has a sandbox escape via unblocked cross-realm Symbol.for keys + missing bridge write-trap symbol checks

CVE-2026-47135GHSA-m5q2-4fm3-vfqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.3
    Fixed in
    3.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-47135: 0.27% estimated exploitation activity in the next 30 days; percentile 18.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vm2 3.11.2 Symbol.for override in setup-sandbox.js only intercepts 2 of 9 dangerous Node.js cross-realm symbols. Combined with the bridge's set/defineProperty/deleteProperty traps having no isDangerousCrossRealmSymbol key check, sandbox code can obtain real cross-realm symbols, write them to host objects, and control host-side behavior — verified with a full util.promisify hijack chain. Root Cause 1. Incomplete Symbol.for override (setup-sandbox.js:132-142): Only inspect.custom and rejection are blocked. The following 7 Node.js internal symbols pass through as real cross-realm symbols: - nodejs.util.promisify.custom - nodejs.stream.readable - nodejs.stream.writable - nodejs.stream.duplex - nodejs.stream.transform - nodejs.webstream.isClosedPromise - nodejs.webstream.controllerErrorFunction Note: bridge.js isDangerousCrossRealmSymbol covers promisify.custom on reads, but the Symbol.for override in setup-sandbox does not block it at the source. 2. Missing symbol check in bridge…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m5q2-4fm3-vfqp

  2. Revision 1 · created ·

    Published from osv record GHSA-m5q2-4fm3-vfqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47135

Advisory: vm2 has a sandbox escape via unblocked cross-realm Symbol.for keys + missing bridge write-trap symbol checks
IDs: CVE-2026-47135, GHSA-m5q2-4fm3-vfqp
Record: https://patchnext.com/advisories/cve-2026-47135 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.3; fixed in 3.11.4

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m5q2-4fm3-vfqp (OSV record GHSA-m5q2-4fm3-vfqp lists affected ranges: npm vm2 >=0 <3.11.4 (fixed))
- Verified: https://github.com/advisories/GHSA-m5q2-4fm3-vfqp (GitHub-reviewed advisory GHSA-m5q2-4fm3-vfqp lists affected ranges: npm vm2 >=0 <=3.11.3)

Commands are suggestions: review each one before running it.

Loading voting…