phpMyFAQ: SQL LIKE Wildcard Injection in Chat User Search Allows Authenticated User Enumeration
CVE-2026-47132GHSA-6pvm-2vjj-rx4w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 4.2.0-alpha), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist thorsten/phpmyfaq
- Affected
- < 4.2.0-alpha
- Fixed in
- 4.2.0-alpha
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6pvm-2vjj-rx4w lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.2.0-alpha (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6pvm-2vjj-rx4w lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.2.0-alpha
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-47132: 0.25% estimated exploitation activity in the next 30 days; percentile 16.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated SQL LIKE wildcard injection vulnerability in phpMyFAQ’s chat user search allows any logged-in user to bypass the intended display-name search filter and enumerate active users. The endpoint escapes SQL string syntax but does not escape % and , which remain active LIKE wildcards.
Details The vulnerable endpoint is: Source: Sink: escape() prevents SQL string breakout, but it does not escape SQL LIKE metacharacters. Therefore, attacker-controlled % and are interpreted by the database as wildcards. The project already uses a safer pattern elsewhere with ESCAPE '|' and wildcard escaping, but this chat search path does not apply it.
PoC: Tested against: phpMyFAQ 4.2.0-alpha commit c0b7158df4bfb11d57b1ef7d471760583c9c2fae Prerequisite: attacker has any valid authenticated user account. 1. Ensure there are multiple active users in the database, for example: 2. Send a normal query that should not match any user: Observed response: 3. Send a wildcard query:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6pvm-2vjj-rx4w
- Revision 1 · created ·
Published from osv record GHSA-6pvm-2vjj-rx4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47132 Advisory: phpMyFAQ: SQL LIKE Wildcard Injection in Chat User Search Allows Authenticated User Enumeration IDs: CVE-2026-47132, GHSA-6pvm-2vjj-rx4w Record: https://patchnext.com/advisories/cve-2026-47132 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 4.2.0-alpha. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist thorsten/phpmyfaq: affected < 4.2.0-alpha; fixed in 4.2.0-alpha ## Suggested inspection (read-only) - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6pvm-2vjj-rx4w (OSV record GHSA-6pvm-2vjj-rx4w lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.2.0-alpha (fixed)) - Verified: https://github.com/advisories/GHSA-6pvm-2vjj-rx4w (GitHub-reviewed advisory GHSA-6pvm-2vjj-rx4w lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.2.0-alpha) Commands are suggestions: review each one before running it.
Loading voting…