Skip to content

← Actionable
Critical, CVSS 9.3amended

OpenMed vulnerable to remote code injection through privacy-filter model loading path

CVE-2026-47117GHSA-m3v4-v5gx-7wf5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmed 1.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openmed

    Affected
    < 1.5.2
    Fixed in
    1.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-47117: 0.92% estimated exploitation activity in the next 30 days; percentile 60.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenMed before 1.5.2 contains a remote code execution vulnerability in the PII privacy-filter model loading path. The privacy-filter dispatcher used broad substring matching on the user-supplied modelname parameter, allowing a value such as attacker/foo-privacy-filter-bar to route through a path that loads Hugging Face models with trustremotecode=True. An unauthenticated attacker can supply a malicious model repository containing custom Transformers code via automap in config.json or tokenizerconfig.json, which is imported and executed with the privileges of the OpenMed service process.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-m3v4-v5gx-7wf5

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-m3v4-v5gx-7wf5

  4. Revision 1 · created ·

    Published from ghsa record GHSA-m3v4-v5gx-7wf5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47117

Advisory: OpenMed vulnerable to remote code injection through privacy-filter model loading path
IDs: CVE-2026-47117, GHSA-m3v4-v5gx-7wf5
Record: https://patchnext.com/advisories/cve-2026-47117 (revision 4, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openmed 1.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openmed: affected < 1.5.2; fixed in 1.5.2

## Suggested inspection (read-only)
- `python -m pip show openmed`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openmed.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m3v4-v5gx-7wf5 (GitHub-reviewed advisory GHSA-m3v4-v5gx-7wf5 lists affected ranges: PyPI openmed >=0 <1.5.2)
- Verified: https://osv.dev/vulnerability/GHSA-m3v4-v5gx-7wf5 (OSV record GHSA-m3v4-v5gx-7wf5 lists affected ranges: PyPI openmed >=0 <1.5.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…