Skip to content

← Actionable
Critical, CVSS 9.3amended

python-statemachine SCXML Eval Injection

CVE-2026-47103GHSA-v4jc-pm6r-3vj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-statemachine 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-47103: 1.36% estimated exploitation activity in the next 30 days; percentile 71.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary python-statemachine 3.1.2 evaluates <data expr="..." attributes in SCXML documents using Python's eval(). Any application that passes attacker-controlled SCXML content to SCXMLProcessor is vulnerable to arbitrary code execution in the context of the hosting process. Details SCXMLProcessor.parsescxmlfile() processes SCXML documents and evaluates <data element expr attributes via the following call chain: eval() calls Python's built-in eval() directly on the expression string without sandboxing or restriction. PoC Impact This is an eval injection vulnerability (CWE-95). Remote or local code execution depending on whether the consuming application accepts SCXML content from remote users, uploaded files, configuration, plugins, or other untrusted sources.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-v4jc-pm6r-3vj8

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-v4jc-pm6r-3vj8

  4. Revision 1 · created ·

    Published from ghsa record GHSA-v4jc-pm6r-3vj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47103

Advisory: python-statemachine SCXML Eval Injection
IDs: CVE-2026-47103, GHSA-v4jc-pm6r-3vj8
Record: https://patchnext.com/advisories/cve-2026-47103 (revision 4, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-statemachine 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-statemachine: affected >= 3.0.0, < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `python -m pip show python-statemachine`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-statemachine.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v4jc-pm6r-3vj8 (GitHub-reviewed advisory GHSA-v4jc-pm6r-3vj8 lists affected ranges: PyPI python-statemachine >=3.0.0 <3.2.0)
- Verified: https://osv.dev/vulnerability/GHSA-v4jc-pm6r-3vj8 (OSV record GHSA-v4jc-pm6r-3vj8 lists affected ranges: PyPI python-statemachine >=3.0.0 <3.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…