Skip to content

← Actionable
Medium, CVSS 5.9

TYPO3 ke_search path traversal from arbitrary table configuration input

CVE-2026-46723GHSA-67j3-jmm3-32xc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tpwd/ke_search 7.0.1, 6.6.1, 5.6.2, 4.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist tpwd/ke_search

    Affected
    >= 7.0.0, < 7.0.1>= 6.0.0, < 6.6.1>= 5.0.0, < 5.6.2< 4.6.7
    Fixed in
    7.0.1, 4.6.7, 5.6.2, 6.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-46723: 0.32% estimated exploitation activity in the next 30 days; percentile 24.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In TYPO3 faceted fulltext search (kesearch), theadditionaltables configuration of the page and ttcontent indexers accept arbitrary table and field names. A backend user with permission to edit indexer configurations can copy sensitive data from internal TYPO3 tables into the search index. This has been patched in versions 7.0.1, 6.6.1, 5.6.2 and 4.6.7.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-67j3-jmm3-32xc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46723

Advisory: TYPO3 ke_search path traversal from arbitrary table configuration input
IDs: CVE-2026-46723, GHSA-67j3-jmm3-32xc
Record: https://patchnext.com/advisories/cve-2026-46723 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tpwd/ke_search 7.0.1, 6.6.1, 5.6.2, 4.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist tpwd/ke_search: affected >= 7.0.0, < 7.0.1; >= 6.0.0, < 6.6.1; >= 5.0.0, < 5.6.2; < 4.6.7; fixed in 7.0.1, 4.6.7, 5.6.2, 6.6.1

## Suggested inspection (read-only)
- Packagist tpwd/ke_search: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tpwd/ke_search.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-67j3-jmm3-32xc (GitHub-reviewed advisory GHSA-67j3-jmm3-32xc lists affected ranges: Packagist tpwd/ke_search >=7.0.0 =6.0.0 =5.0.0 =0 <4.6.7)

Commands are suggestions: review each one before running it.

Loading voting…