Skip to content

← Actionable
Medium, CVSS 6.9

TYPO3 sf_register extension allows unauthorized assignment of frontend user groups

CVE-2026-46721GHSA-v348-vr4q-fv9p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (evoweb/sf-register 14.0.2, 13.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-46721: 0.36% estimated exploitation activity in the next 30 days; percentile 30.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The create and edit flows in the TYPO3 extension sfregister do not restrict which user properties may be submitted, and do not enforce access control on the frontend user group assignment. As a result, an attacker can assign an arbitrary frontend user group to a newly registered or edited account, gaining unauthorized access to content and functionality restricted to privileged frontend user groups.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v348-vr4q-fv9p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46721

Advisory: TYPO3 sf_register extension allows unauthorized assignment of frontend user groups
IDs: CVE-2026-46721, GHSA-v348-vr4q-fv9p
Record: https://patchnext.com/advisories/cve-2026-46721 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: evoweb/sf-register 14.0.2, 13.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist evoweb/sf-register: affected >= 14.0.0, < 14.0.2; < 13.2.4; fixed in 13.2.4, 14.0.2

## Suggested inspection (read-only)
- Packagist evoweb/sf-register: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on evoweb/sf-register.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v348-vr4q-fv9p (GitHub-reviewed advisory GHSA-v348-vr4q-fv9p lists affected ranges: Packagist evoweb/sf-register >=14.0.0 =0 <13.2.4)

Commands are suggestions: review each one before running it.

Loading voting…