Skip to content

← Actionable
Unratedamended

Flask-Security-Too OAuth reauthentication freshness bypass via cross- user OAuth identity acceptance

CVE-2026-46715GHSA-97r5-pg8x-p63p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-security-too 5.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-46715: 0.35% estimated exploitation activity in the next 30 days; percentile 28.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Flask-Security-Too 5.8.0's OAuth reauthentication flow can mark a session as fresh after verifying an OAuth account that belongs to a different user. If an attacker can operate an already-authenticated but stale victim session, they can complete OAuth verification using their own OAuth identity. The victim session is then treated as recently reauthenticated, allowing freshness-protected account actions to proceed. This was reproduced against the built-in /change-username route.

Details The issue is in the OAuth verification callback. oauthresponsecommon() resolves the OAuth provider identity to a Flask-Security user: - flasksecurity/oauthglue.py:101-108 oauthverifyresponse() then accepts any resolved user and updates the current session freshness timestamp: - flasksecurity/oauthglue.py:182-214 - flasksecurity/oauthglue.py:201-204 The missing check is that the OAuth-resolved user must match the current authenticated session user. In the failing case: - current session…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-97r5-pg8x-p63p

  2. Revision 1 · created ·

    Published from osv record GHSA-97r5-pg8x-p63p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46715

Advisory: Flask-Security-Too OAuth reauthentication freshness bypass via cross- user OAuth identity acceptance
IDs: CVE-2026-46715, GHSA-97r5-pg8x-p63p
Record: https://patchnext.com/advisories/cve-2026-46715 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-security-too 5.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-security-too: affected >= 5.8.0, < 5.8.1; fixed in 5.8.1

## Suggested inspection (read-only)
- `python -m pip show flask-security-too`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-security-too.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-97r5-pg8x-p63p (OSV record GHSA-97r5-pg8x-p63p lists affected ranges: PyPI flask-security-too >=5.8.0 <5.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-97r5-pg8x-p63p (GitHub-reviewed advisory GHSA-97r5-pg8x-p63p lists affected ranges: PyPI flask-security-too >=5.8.0 <5.8.1)

Commands are suggestions: review each one before running it.

Loading voting…