justhtml introduces denial-of-service hardening
CVE-2026-4671GHSA-r8cj-3554-33mr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI justhtml
- Affected
- < 1.18.0
- Fixed in
- 1.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r8cj-3554-33mr lists affected ranges: PyPI justhtml >=0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r8cj-3554-33mr lists affected ranges: PyPI justhtml >=0 <1.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-4671: 0.65% estimated exploitation activity in the next 30 days; percentile 51.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary justhtml 1.18.0 fixes multiple low-severity denial-of-service hardening issues in CSS selector handling and linkification. These issues are availability concerns. They do not allow script execution, data disclosure, or sanitizer bypass by themselves. Affected versions - justhtml < 1.18.0 Fixed version - justhtml 1.18.0 released on May 4, 2026 Impact CSS selector handling Applications that evaluate attacker-controlled selector strings, or that run selector-based transform pipelines over attacker-controlled documents, could consume disproportionate CPU or memory. The affected selector patterns included oversized selectors, large selector lists, oversized compound selectors, long combinator chains, deeply nested functional pseudo-classes such as :not(...), repeated attribute/class token matching over large values, repeated sibling or ancestor scans, repeated positional pseudo-class work, and :contains(...) over large descendant text. Programmatically constructed malformed DOM…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r8cj-3554-33mr
- Revision 1 · created ·
Published from osv record GHSA-r8cj-3554-33mr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-4671 Advisory: justhtml introduces denial-of-service hardening IDs: CVE-2026-4671, GHSA-r8cj-3554-33mr Record: https://patchnext.com/advisories/cve-2026-4671 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: justhtml 1.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI justhtml: affected < 1.18.0; fixed in 1.18.0 ## Suggested inspection (read-only) - `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on justhtml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r8cj-3554-33mr (OSV record GHSA-r8cj-3554-33mr lists affected ranges: PyPI justhtml >=0 <1.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r8cj-3554-33mr (GitHub-reviewed advisory GHSA-r8cj-3554-33mr lists affected ranges: PyPI justhtml >=0 <1.18.0) Commands are suggestions: review each one before running it.
Loading voting…