Skip to content

← Actionable
Critical, CVSS 9.6amended

Boxlite: Path Traversal Vulnerability Leads to Arbitrary File Write on the Host

CVE-2026-46703GHSA-f396-4rp4-7v2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (boxlite 0.9.0; boxlite 0.9.0; boxlite-cli 0.9.0; @boxlite-ai/boxlite 0.9.0; github.com/boxlite-ai/boxlite/sdks/go 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-46703: 0.48% estimated exploitation activity in the next 30 days; percentile 41.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Boxlite is a sandbox service that allows users to create lightweight virtual machines (Boxes) and run OCI containers within them. Boxlite allows users to specify the OCI image used by containers in the sandbox. However, when processing tar entries in OCI images, Boxlite does not account for the possibility that entries may be symlinks pointing to absolute paths. An attacker can craft a malicious OCI image and distribute it on image hosting platforms such as DockerHub, tricking users into using it. Once a user loads the malicious image, the attacker can write arbitrary content to any path on the host, which can further lead to remote code execution on the host. Details 1. Entry Point — OCI Layer Tarball Extraction File: boxlite/src/images/archive/tar.rs Function: extractlayertarballstreaming() (line 24) Code: Issue: The function passes the tar reader into applyocilayer. The tarball comes from a registry blob that has passed SHA256 integrity verification against the manifest…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f396-4rp4-7v2j

  2. Revision 2 · amended ·

    Amended from osv record GHSA-f396-4rp4-7v2j

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f396-4rp4-7v2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46703

Advisory: Boxlite: Path Traversal Vulnerability Leads to Arbitrary File Write on the Host
IDs: CVE-2026-46703, GHSA-f396-4rp4-7v2j
Record: https://patchnext.com/advisories/cve-2026-46703 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: boxlite 0.9.0; boxlite 0.9.0; boxlite-cli 0.9.0; @boxlite-ai/boxlite 0.9.0; github.com/boxlite-ai/boxlite/sdks/go 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io boxlite: affected < 0.9.0; fixed in 0.9.0
- PyPI boxlite: affected < 0.9.0; fixed in 0.9.0
- crates.io boxlite-cli: affected < 0.9.0; fixed in 0.9.0
- npm @boxlite-ai/boxlite: affected < 0.9.0; fixed in 0.9.0
- Go github.com/boxlite-ai/boxlite/sdks/go: affected < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- crates.io boxlite: check the installed version with your package manager.
- `python -m pip show boxlite`: prints the installed version. Run with the environment that serves production active.
- crates.io boxlite-cli: check the installed version with your package manager.
- `npm ls @boxlite-ai/boxlite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Go github.com/boxlite-ai/boxlite/sdks/go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on boxlite, boxlite-cli, @boxlite-ai/boxlite, github.com/boxlite-ai/boxlite/sdks/go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f396-4rp4-7v2j (GitHub-reviewed advisory GHSA-f396-4rp4-7v2j lists affected ranges: PyPI boxlite >=0 =0 <0.9.0)
- Verified: https://osv.dev/vulnerability/GHSA-f396-4rp4-7v2j (OSV record GHSA-f396-4rp4-7v2j lists affected ranges: PyPI boxlite >=0 =0 =0 =0 =0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f396-4rp4-7v2j (GitHub-reviewed advisory GHSA-f396-4rp4-7v2j lists affected ranges: PyPI boxlite >=0 =0 =0 =0 =0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…