Network-AI: Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret
CVE-2026-46701GHSA-j3vx-cx2r-pvg8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm network-ai
- Affected
- <= 5.4.4
- Fixed in
- 5.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3vx-cx2r-pvg8 lists affected ranges: npm network-ai >=0 <5.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3vx-cx2r-pvg8 lists affected ranges: npm network-ai >=0 <=5.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-46701: 0.21% estimated exploitation activity in the next 30 days; percentile 11.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret | Field | Value | | ---------------- | ----- | | Repository | Jovancoding/Network-AI | | Affected version | v5.4.4 (commit c12686e181f231cf8d7bcf836a96d78f0f0877ac) | Summary The MCP SSE server defaults to an empty secret (process.env['NETWORKAIMCPSECRET'] ?? '' at bin/mcp-server.ts:89), which causes isAuthorized (lib/mcp-transport-sse.ts:254) to return true unconditionally for every request — no Authorization header is required. Simultaneously, handleRequest sets Access-Control-Allow-Origin: (lib/mcp-transport-sse.ts:272) on every response, so a cross-origin browser fetch can read the result without restriction. An unauthenticated attacker who can lure a user to a malicious web page can invoke all 22 exposed MCP tools — including configset, agentspawn, and blackboardwrite — against a default-configured localhost server. Affected Code bin/mcp-server.ts:89 — default secret resolves to empty string, enabling open…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j3vx-cx2r-pvg8
- Revision 1 · created ·
Published from osv record GHSA-j3vx-cx2r-pvg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46701 Advisory: Network-AI: Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret IDs: CVE-2026-46701, GHSA-j3vx-cx2r-pvg8 Record: https://patchnext.com/advisories/cve-2026-46701 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: network-ai 5.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm network-ai: affected <= 5.4.4; fixed in 5.4.5 ## Suggested inspection (read-only) - `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on network-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3vx-cx2r-pvg8 (OSV record GHSA-j3vx-cx2r-pvg8 lists affected ranges: npm network-ai >=0 <5.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-j3vx-cx2r-pvg8 (GitHub-reviewed advisory GHSA-j3vx-cx2r-pvg8 lists affected ranges: npm network-ai >=0 <=5.4.4) Commands are suggestions: review each one before running it.
Loading voting…