Skip to content

← Actionable
Medium, CVSS 4.3amended

@actual-app/sync-server's missing authorization on GET /secret/:name allows non-admin OpenID users to enumerate admin-configured bank-sync secrets

CVE-2026-46700GHSA-3f62-qv96-4p78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-46700: 0.25% estimated exploitation activity in the next 30 days; percentile 16.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In @actual-app/sync-server, the GET /secret/:name endpoint (app-secrets.js:53) checks only that the caller has a valid session — it does not verify the caller is an admin. The sibling POST /secret/ handler does enforce an admin check in OpenID mode, exposing an authorization asymmetry. Any authenticated non-admin (BASIC) user in OpenID multi-user deployments can probe the secrets store and learn which admin-managed bank-sync integrations have been configured (existence, not values). This includes integration credentials that are not otherwise observable to non-admins, such as simplefinaccessKey, pluggyaiclientSecret, pluggyaiitemIds, and the gocardless secrets. Details packages/sync-server/src/app-secrets.js mounts validateSessionMiddleware at the router level (line 15), so all handlers inherit only "must be authenticated." The POST handler then explicitly upgrades to an admin check when the active auth method is openid: The sibling GET handler skips both the method check and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3f62-qv96-4p78

  2. Revision 1 · created ·

    Published from osv record GHSA-3f62-qv96-4p78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46700

Advisory: @actual-app/sync-server's missing authorization on GET /secret/:name allows non-admin OpenID users to enumerate admin-configured bank-sync secrets
IDs: CVE-2026-46700, GHSA-3f62-qv96-4p78
Record: https://patchnext.com/advisories/cve-2026-46700 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @actual-app/sync-server: affected < 26.6.0; fixed in 26.6.0

## Suggested inspection (read-only)
- `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @actual-app/sync-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3f62-qv96-4p78 (OSV record GHSA-3f62-qv96-4p78 lists affected ranges: npm @actual-app/sync-server >=0 <26.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3f62-qv96-4p78 (GitHub-reviewed advisory GHSA-3f62-qv96-4p78 lists affected ranges: npm @actual-app/sync-server >=0 <26.6.0)

Commands are suggestions: review each one before running it.

Loading voting…