Skip to content

← Actionable
Low, CVSS 3.3amended

October CMS: Safe Mode Sandbox Bypass via Session Store and Forwarded Builder Calls

CVE-2026-46696GHSA-xv9m-fm3w-8w5x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 4.2.23, 3.7.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    < 3.7.17>= 4.0.0, < 4.2.23
    Fixed in
    4.2.23, 3.7.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-46696: 0.27% estimated exploitation activity in the next 30 days; percentile 19.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was identified in the Twig sandbox security policy that allowed a chained bypass when cms.safemode is enabled. The Laravel session store was exposed to Twig with unrestricted method access, and raw SQL methods reachable through Eloquent's call forwarding were not blocked across the full builder chain. When combined, a backend user with CMS markup editing access could read arbitrary database values via raw SQL expressions and write to the backend authentication session key, forging a backend session as another existing user. Scope of impact is narrow. Safe Mode is a niche feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. Standard production deployments do not enable Safe Mode, because under normal October CMS guidance backend access - including markup editing - is restricted to trusted administrators, and direct PHP injection through markup is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xv9m-fm3w-8w5x

  2. Revision 1 · created ·

    Published from osv record GHSA-xv9m-fm3w-8w5x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46696

Advisory: October CMS: Safe Mode Sandbox Bypass via Session Store and Forwarded Builder Calls
IDs: CVE-2026-46696, GHSA-xv9m-fm3w-8w5x
Record: https://patchnext.com/advisories/cve-2026-46696 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 4.2.23, 3.7.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected < 3.7.17; >= 4.0.0, < 4.2.23; fixed in 4.2.23, 3.7.17

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xv9m-fm3w-8w5x (OSV record GHSA-xv9m-fm3w-8w5x lists affected ranges: Packagist october/system >=0 =4.0.0 <4.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-xv9m-fm3w-8w5x (GitHub-reviewed advisory GHSA-xv9m-fm3w-8w5x lists affected ranges: Packagist october/system >=0 =4.0.0 <4.2.23)

Commands are suggestions: review each one before running it.

Loading voting…