Snappy : SSRF and local file read via the xsl-style-sheet option
CVE-2026-46683GHSA-c5fp-p67m-gq56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (knplabs/knp-snappy 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist knplabs/knp-snappy
- Affected
- <= 1.6.0
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5fp-p67m-gq56 lists affected ranges: Packagist knplabs/knp-snappy >=0 <=1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-46683: 0.25% estimated exploitation activity in the next 30 days; percentile 16.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It impacts applications where: - the PHP daemon run with root permissions ; - the application is either running outside a container or has sensitive file access ; It could happens with this kind of workflows: Patches A list a schema with http and https by default is used to validate the remote path by default. Workarounds Developers should ensure usage cannot allow (in any case) a user to pass a free input directly to the Snappy library. Instead developers can list available available stylesheets and pick the right one with the user input. References Read more about SSRF at owasp.org/www-community/attacks/ServerSideRequestForgery
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5fp-p67m-gq56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46683 Advisory: Snappy : SSRF and local file read via the xsl-style-sheet option IDs: CVE-2026-46683, GHSA-c5fp-p67m-gq56 Record: https://patchnext.com/advisories/cve-2026-46683 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: knplabs/knp-snappy 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist knplabs/knp-snappy: affected <= 1.6.0; fixed in 1.7.0 ## Suggested inspection (read-only) - Packagist knplabs/knp-snappy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on knplabs/knp-snappy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5fp-p67m-gq56 (GitHub-reviewed advisory GHSA-c5fp-p67m-gq56 lists affected ranges: Packagist knplabs/knp-snappy >=0 <=1.6.0) Commands are suggestions: review each one before running it.
Loading voting…