Skip to content

← Actionable
High, CVSS 7.5amended

js-libp2p: Memory DoS via subscription flood of unique topics

CVE-2026-46679GHSA-4f8r-922h-2vgv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@libp2p/gossipsub 15.0.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-46679: 0.28% estimated exploitation activity in the next 30 days; percentile 20.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Three cooperating omissions in @libp2p/gossipsub allow an unauthenticated single peer to exhaust the Node.js heap of any gossipsub node with default options. 1. defaultDecodeRpcLimits.maxSubscriptions = Infinity (packages/gossipsub/src/message/decodeRpc.ts:11): no decode-level cap on subscription entries per RPC. 2. handleReceivedSubscription is unbounded (gossipsub.ts:1009-1021): every unique topic string creates a new Map entry + Set object in this.topics with no per-peer count limit. 3. removePeer leaves empty Sets (gossipsub.ts:782-784): after peer disconnect, empty Sets are never deleted from this.topics thus memory is non-reclaimable within the process lifetime. A single 4MB LP frame carries 349,525 unique topic SUBSCRIBE entries. Each frame causes ~89MB of heap growth (~22x amplification). A Node.js process with a 1.5GB heap limit crashes after ~17 such frames (~68MB total attacker bandwidth, achievable in ~5 seconds at 100Mbps). Details Defect 1:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4f8r-922h-2vgv

  2. Revision 1 · created ·

    Published from osv record GHSA-4f8r-922h-2vgv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46679

Advisory: js-libp2p: Memory DoS via subscription flood of unique topics
IDs: CVE-2026-46679, GHSA-4f8r-922h-2vgv
Record: https://patchnext.com/advisories/cve-2026-46679 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @libp2p/gossipsub 15.0.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @libp2p/gossipsub: affected <= 15.0.22; fixed in 15.0.23

## Suggested inspection (read-only)
- `npm ls @libp2p/gossipsub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @libp2p/gossipsub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4f8r-922h-2vgv (OSV record GHSA-4f8r-922h-2vgv lists affected ranges: npm @libp2p/gossipsub >=0 <15.0.23 (fixed))
- Verified: https://github.com/advisories/GHSA-4f8r-922h-2vgv (GitHub-reviewed advisory GHSA-4f8r-922h-2vgv lists affected ranges: npm @libp2p/gossipsub >=0 <=15.0.22)

Commands are suggestions: review each one before running it.

Loading voting…